Telnet command fails with telnet: /lib64/libc.so.6: version `GLIBC_2.15′ not found (required by telnet)

Yesterday one of my customer had issue with running telnet command on exadata server. It was failing with below error:


[root@extestserver ~]# telnet
telnet: /lib64/libc.so.6: version `GLIBC_2.15' not found (required by telnet)

I asked him to provide me details like telnet version & kernel version running on the server:


[root@extestserver ~]# imageinfo
Kernel version: 2.6.39-400.294.4.el6uek.x86_64 #1 SMP Tue Mar 14 18:42:17 PDT 2017 x86_64
Image kernel version: 2.6.39-400.294.4.el6uek
Image version: 12.1.2.3.5.170418
Image activated: 2017-08-25 11:55:37 +0300
Image status: success
System partition on device: /dev/mapper/VGExaDb-LVDbSys1

[root@extestserver ~]# rpm -qa |grep telnet
telnet-1.2-166.4.1.x86_64

From error, obviously telnet rpm was installed on the server but it was not compatible with GLIBC rpm installed on the server.

The installed telnet rpms output shows the version of telnet which is not available in Oracle’s public yum repository So customer had installed it from outside oracle’s yum public repository.

From Oracle’s public yum repository, I found, supported telnet version on OEL6 is telnet-0.17-48.el6.x86_64.rpm.

So I asked customer to uninstall current telnet installed on the server & install supported one.


rpm -e telnet-1.2-166.4.1.x86_64
rpm -ivh telnet-0.17-48.el6.x86_64.rpm

Telnet started working as expected 🙂

Hope so u will find this post very useful:-)

Cheers

Regards,
Adityanath

 

 

 

 

Advertisements